Desenvolva um programa que dados três números inteiros, inform...

Desenvolva um programa que dados três números inteiros, informe quantos são negativos.

1 Resposta

KimberllyKethley

1.  

A) Falso

B)Falso

C) Verdadeiro

D)Falso

2.  

algoritmo "semnome"

var

HT, VH, PH, SB, TD, PD, SL:real

inicio

    escreva ("Escreva o valor de horas trabalhadas: ")

    leia (HT)

    Escreva ("Escreva o valor da hora trabalhada: R$")

    Leia (VH)

    Escreva ("escreva o percentual de desconto: ")

    leia (PD)

    SB <- HT * VH

    TD <- (PD/100)*SB

    SL <- SB - TD

    escreval ("")

    escreval ("Horas trabalhadas: ", HT, " horas")

    escreval ("Valor por hora: R$", VH)

    escreval ("Percentual de desconto:", PD,"%")

    escreval ("")

    escreval ("O salário bruto foi de :R$", SB)

    escreval ("O desconto foi de : R$", TD)

    escreval ("O salário liquido foi de: R$", SL)

fimalgoritmo

3.

algoritmo "semnome"

var

   C, F : Real

inicio

     Escreva ("Escreva a temperatura em ºC: ")

     leia (C)

     F <- (9 * C + 160)/5

     escreval ("A temperatura em Fahrenheit é: ", F,)

fimalgoritmo

4.

algoritmo "semnome"

var

  F, C: real

inicio

     escreva ("Escreva a temperatura em F: ")

     leia (F)

     C <- (F - 32) * (5 / 9)

     escreval ("A temperatura em ºC é: ", C)

fimalgoritmo

5.

algoritmo "semnome"

var

   C, L, A, V: real

inicio

     escreva ("Escreva o comprimento da caixa: ")

     leia (C)

     escreva ("Escreva a largura da caixa: ")

     leia (L)

     escreva ("Escreva a altura da caixa: ")

     leia (A)

     V <- C * L * A

     escreval ("O volume da caixa é: ", V)

fimalgoritmo

6.

algoritmo "semnome"

var

  N, Q, C : inteiro

inicio

     escreva ("Escreva um valor inteiro: ")

     leia (N)

     Q <- N * N

     C <- N * N * N

     escreval ("")

     escreval ("O valor de ", N, " ao quadrado é: ", Q)

     escreval ("O valor de ", N, " ao cubo é: ", C)

fimalgoritmo

7. Não sei.

8.

algoritmo "semnome"

var

  N: real

inicio

     escreva ("Digite um número: ")

     leia (N)

     se (N < 10) entao

        escreva ("F1")

     FimSe

     Se (N > 10) e (N <=100)entao

        escreva("F2")

     FimSe

     Se (N > 100)entao

        escreva("F3")

     FimSe

fimalgoritmo

9.

algoritmo "semnome"

var

  A, B, C, CAL: real

inicio

     escreva ("Informe o valor de A: ")

     leia (A)

     escreva ("Informe o valor de B: ")

     leia (B)

     escreva ("Informe o valor de C: ")

     leia (C)

     CAL <- A + B

     se (CAL < C)entao

        escreva (A, " + ", B,  " é menor que ", C)

     FimSe

     Se (CAL = C)entao

        escreva (A, " + ", B,  " é igual a ", C)

     FimSe

     Se (CAL > C)entao

        escreva (A, " +", B,  " é maior que", C)

     FimSe

fimalgoritmo

10.

algoritmo "semnome"

var

  B, S, SQ, D: real

inicio

     escreval ("[1] Para ver o saldo")

     escreval ("[2] Para sacar")

     escreval ("[3] Para depositar")

     leia (B)

     S <- 300

     escolha B

             caso 1

                  escreva ("O saldo atual é: ", S)

             caso 2

                  escreva ("Digite o valor do saque: ")

                  leia (SQ)

                  S <- S - SQ

                  se (S > 0)entao

                     Escreval ("O Saldo atual é :", S)

                  senao

                     Escreval ("Conta estourada")

                  FimSe

             caso 3

                  escreva ("Digite o valor do depósito: ")

                  leia (D)

                  S <- S + D

                  escreva ("O Saldo atual é :", S)

     FimEscolha

fimalgoritmo

11.

algoritmo "semnome"

var

   N, O: real

inicio

     escreva ("Digite o número : ")

     leia (N)

     escreval ("[1] Raiz quadrada")

     escreval ("[2] A metade")

     escreval ("[3] 10% do número")

     escreval ("[4] O dobro")

     escreva  ("Escolha uma opção: ")

     leia (O)

     escolha O

             caso 1

                  escreva ("A  raiz quadrada de ",N, " é:")

                  escreval (raizQ (N))

             caso 2

                  escreva ("A Metade de ",N, " é: ")

                  escreval (N / 2)

             caso 3

                  escreva ("10% de ",N, " é: ")

                  escreval ((10 * N)/ 100)

             caso 4

                  escreva ("O dobro de ",N, "é: ")

                  escreval (N * 2)

     FimEscolha

fimalgoritmo

12. Não Sei

13.

algoritmo "semnome"

var

  cont: inteiro

inicio

     para cont de 85 ate 907 passo 2 faca

          escreval (cont -1)

     FimPara

fimalgoritmo

14.

algoritmo "semnome"

var

  O:inteiro

inicio

Escreval ("++")

Escreval ("|     Opcões      |")

escreval ("++")

Escreval ("[1] Solteiro(a)")

Escreval ("[2] Casado(a)")

Escreval ("[3] Viuvo (a)")

Escreval ("[4] Divorciado(a)")

Escreval ("[5] Desquitado(a)")

Escreva  ("Digite Uma Opcão: ")

leia (O)

se (O = 1 )entao

  escreval ("Solteiro(a).")

fimse

se(O = 2 )entao

  escreval ("Casado(a).")

fimse

se (O = 3 )entao

  escreval ("Viúvo(a).")

fimse

se (O = 4 )entao

   escreval ("Divorciado(a).")

fimse

se (O = 5 )entao

   escreval ("Desquitado(a).")

fimse

se (O > 5)entao

   escreval ("Selecione número de 1 a 5 de acordo como menu de opções.")

fimse

fimalgoritmo

15. não sei

16. não sei

17.

algoritmo "semnome"

var

  num, qtd_pares, qtd_impares: inteiro

inicio

  qtd_pares <- 0

  qtd_impares <- 0

  escreva("Informe um número (9999 para encerrar): ")

  leia(num)

  enquanto (num <> 9999) faca

     se (num % 2 = 0) entao

        qtd_pares <- qtd_pares + 1

     senao

        qtd_impares <- qtd_impares + 1

     fimse

     escreva("Informe um número (9999 para encerrar): ")

     leia(num)

  fimenquanto

  escreval("Quantidade de pares: ", qtd_pares)

  escreval("Quantidade de ímpares: ", qtd_impares)

fimalgoritmo

18. Não sei

19.

algoritmo "semnome"

var

N: real

inicio

escreva ("Informe o número: ")

leia (N)

    repita

          N<- ((N) / (2))

          escreval ("")

          escreval(N)

    ate ((N) < (1))

fimalgoritmo

Aí amigo, teve algumas questões que não consegui resolver, mais eu tentei, só não tive sucesso!

Sua resposta
Ok

Mais perguntas de Lógica





















Toda Materia
Toda Materia
Toda Materia

Você tem alguma dúvida?

Faça sua pergunta e receba a resposta de outros estudantes.